Amstrad 1640 not booting up

Want to talk about your hardware setup? Brag about your super-machine's layout? Pretend you know a lot about computers? You can do all that and more in this forum.
Post Reply
User avatar
Noaboss
Member
Member
Posts: 20
Joined: Wed Sep 06, 2023 7:07 pm
Location: Down under in Australia

Amstrad 1640 not booting up

Post by Noaboss »

Hi I recently found an old Amstrad 1640 under a sheet in a garage, it was booting up earlier but I accidentally unplugged it from the power supply and now when I try to turn it on the hard drive light flashes for a second and then nothing happened, Is it a hardware or corrupted hard drive issue?
If you have any idea what's wrong please let me know soon as possible.

Edit/update: I found out that the hard drive is corrupted (I will probably replace it with a floppy emulator drive sometime in the near future) so I disconnected that from the motherboard and now it boots up, however it gives me two error messages:
"ERROR: Faulty system RAM"
and sometimes it also says this:
"ERROR: Faulty serial port"
Last edited by Noaboss on Thu Feb 15, 2024 9:40 pm, edited 2 times in total.
ImageLemon64 Profile
Plays dos games way too much 'nuff said
User avatar
Rwolf
Gaming Demi-god
Gaming Demi-god
Posts: 1549
Joined: Fri Jan 11, 2013 3:19 pm
Location: Sweden

Amstrad 1640 not booting up

Post by Rwolf »

No experience with Amstrad, sorry. Try asking at Vogons.org perhaps they are more knowing.
User avatar
Noaboss
Member
Member
Posts: 20
Joined: Wed Sep 06, 2023 7:07 pm
Location: Down under in Australia

Amstrad 1640 not booting up

Post by Noaboss »

Ok, thanks for letting me know (:
ImageLemon64 Profile
Plays dos games way too much 'nuff said
Post Reply