Page 1 of 2

Runner 1.0 Error (Windows 3.1 Game)

Posted: Wed May 03, 2017 10:49 am
by Hennie
To refresh informed readers' memories, Runner 1.0 is an arcade-style game for Windows 3.1/9.x, designed by SouthBay Software in 1993. The concept is similar to those of the "Lode Runner" series, but with some gameplay and playfield differences. The shareware version has 3 levels in total, whilst the registered version apparently has 16.

On my laptop (Windows 7 OS), DOSBox 0.74 is able to run Windows 95 flawlessly, and as a result, most 3.x/9.x games are playable. However, Runner sticks out like a sore thumb, as it cannot run the .EXE file at all. When I do attempt to run the game, up pops an error message saying, "Cannot open RUNNER.DAT Game file!". Here I am unsure whether the problem lies with the .EXE file, the .DAT file or simply because it's running in an emulated Windows 95 instance.

Do take note that this happens with all shareware version (1.0) copies that I've downloaded, as well as with the full, registered version (1.0), which I also possess. The "RUNNER.DAT" file size for both are 3 KB and 16 KB, respectively. Upon inspection, it does have contents (seemingly used as a sample template for the levels) that reads as gibberish. So, there's not definite way to determine if it's corrupted, it's the exact same for all 3 KB copies. The first 3 KB of the full version appears to be the same, with the additional 13 KB new content.

So far, what I've tried was (all resulting in the same error):

- Opening the "RUNNER.DAT" before running the "RUNNER.EXE".
- Renaming either files, or both.
- Changing between different color palettes and resizing the desktop area (Display Properties -> Settings)
- Accessing DOSBox configuration to change between video system outputs (e.g opengl, openglnb) and CPU types (e.g 386_slow, 486_slow, pentium_slow). Probably other stuff too, can't remember.
- Swearing
- Praying

Also, interestingly, this error has been mentioned before once, but on the now-defunct Download-Central gaming archive. The Wayback Machine captured the Runner entry, the poster mentioning that he "...could not get Runner to work in a Windows 3.1 installation in DOSbox, it always claimed it couldn't open RUNNER.DAT. It worked fine under XP, as well as on Windows for Workgroups on a 486..."

This might indicate that one needs specialized settings, or that Runner is simply not meant for DOSBox.

I also tried with Windows for Workgroups 3.11 installed in DOSBox, which returned the same error. Unfortunately I don't have access to an Windows 3.x/9.x/XP machine to try the game out.

Any assistance and advice would be welcome! Thank you in advance! :)

Posted: Wed May 03, 2017 1:03 pm
by Quadko
DOSBox 0.74 is able to run Windows 95 flawlessly
Cool trick! Vanilla .74, or one of the alternate distributions? I haven't had success trying that with vanilla .74, but heard it's possible using alternates or with sweat. Looking forward to getting that working someday, was actually hoping .75 would release "soon" with that capbility, but have been waiting for years now just realized!

However, I have had excellent results running Win 3.x in vanilla dosbox .74. WfWorkgroups is essentially the same, shouldn't lose capability from Win 3.x, just gain a few.

I have a few games that really want Win 2.x, I have a few that complain that 3.x is "too advanced." Don't know about this one, but maybe worth a shot. OTOH, I haven't gotten Win 2.x working either, the install disks try wonky things that confuse DosBox, and internet workarounds didn't. :bday:

"Works in XP" is likely a compatibility layer type solution. Though, did XP even run 16 bit games? Maybe this requires Win32s in Win 3.x, and that's why XP works.

Other thoughts, you may have tried some already:
- I assume Runner.dat is in the same directory as runner.exe; if not give that a try.
- Maybe there's a runner.ini file that is supposed to point to the right directory? Is there one in the archive? Is there an installer?
- If Runner works on XP, maybe it works directly under Windows 7/10/etc?
- Does the dat file belong in a subdir?
- Are long filenames in your host OS throwing it off, potentially? Maybe the name it sees isn't the name you see in the UI. Try the command line /x flag on dir: dir /x - should work on Win 7 & maybe Win 95. Maybe runner.dat got a weird runne~1.dat that the game is seeing through the file api but that Windows 7 & DosBox+Win95 are disguising with the right "long file name".
- Sometimes games treat floppy drives differently, can you mount a simple directory as a floppy drive in dosbox, and try running the game from there?

edit: one other thought; any chance you have a corrupted dat file? Maybe try downloading the shareware edition from different sources? Maybe it "found" the file, but failed to load the expected data and reported error "can't find [correct formatted] dat file!" instead of "can't find [physical] dat file".

Posted: Wed May 03, 2017 2:35 pm
by Hennie
The 0.74 DOSBox version that I'm running has been downloaded straight from the official DOSBOX websote as a Win32 installer, so I'm assuming it's vanilla. It's not an enhanced SVN build, AFAIK. It was after tremendous trail-and-error that I finally got it running, it was ridiculous.

Runner (released in 1993) seems to be designed for 3.x or higher. If I remember correctly, Win 1.x/2.x games give an error stating that it simply needs later Windows versions, so don't think Runner has an compatibility issue regarding that.

XP did run 16 bit, I remember playing SkiFree and Bow & Arrow back in 2011 on our old XP machine, without the need for compatibility settings. You make a good point about it possibly requiring 32s, will see what I can do about that. There's a Win 32s installer for 3.1 that I could try later.

- Both the .DAT and .EXE is in the same directory, even removed the .DAT to no avail.
- There is an .INI that contains the following:


Does anything seem amiss here? Also, there's no installer, just the dropped game files.

- Have tried every compatibility setting, doesn't work, says the version is not compatible.
- No subdir.
- Haven't checked this, and am unsure how, could you clarify next time, please?
- Haven't tried that yet. When I did, just now, it said the game must be run under Windows, so meh.
- I've considered that and tried with at least 7 different copies in the past, what's the odds for all these being corrupted? The registered version has the same error, surely any corrupted files should have been rectified for that release.

Other games that has .DAT files work perfectly, so there's something I'm missing here...or something. :suspicious:

Posted: Thu May 04, 2017 7:03 pm
by Quadko
Haven't checked this, and am unsure how, could you clarify next time, please?
I think you mean my "long filenames / short filenames" item.
To do that, you open a command prompt (I forget what Win95 calls it, is it just the DOS Prompt?).
use CD to change to the game path, like: cd c:\game
then do a directory listing with /x, like: dir /x

Hopefully that works on Win95! When I do it on Windows 10, I see short name (if relevant like Window~1.LOG) and long names like:

Code: Select all

10/30/2015  01:21 AM                92              win.ini
05/04/2017  11:01 AM               275 WINDOW~1.LOG WindowsUpdate.log
Don't know if that helps with the game, but that's at least what I was talking about! :)

Also, I had a problem with a game, Captain Comic 2; every download I could find was corrupted "late" in the game and it thought it was unregistered in spite of being the registered copy. Only one guy had a good copy that I found, and it was specifically to address the "everybody is wrong" problem. So yes, I definitely know that can happen! But might not be the problem with Runner, of course.

Posted: Thu May 04, 2017 11:12 pm
by Quadko
I gave it a try and got the same error. I downloaded one of the shareware versions, I think, and tried it in Win 3.11 in DosBox.

I tried a few of the tricks, and another advanced one that's hard to explain. (ProcMon from sysinternals, watch for file reads.) No solutions yet.

The only thing I noticed was the game didn't "try and fail" to read the dat file, it "gave up without trying". That can happen when it reads a directory for filenames and doesn't detect the name. Weird!

I've got a few more tricks to try later when I have some time. There seem to be screenshots and YouTube vids of the game, so someone seems to be able to get it to run. I wonder if they discuss any tricks? The BBS & .wri readme file didn't have any hints I saw.

edit: Tried a few more tricks, still no joy. But tried installing 256 color, sound drivers, joystick driver, and Win32s. With and without the SmartDrive call.

I notice that a DosBox guide from says
Some things that don't work correctly with Windows 3x in DOSBox:

The "A:" drive, it won't show in Windows File Manager nor in the "run" dialog if you mount an "A:". You can however, enter the path i.e.: "a:\setup.exe". It will show when nothing is mounted as "A:".
32-bit file and disk access doesn't work in DOSBox.
That might be old info, or might be related. It's always possible that the way the game is trying to open the file isn't supported by dosbox. Maybe a non-vanilla dosbox version would work in that case, I know disk access was one thing they worked on for 95/98 support.

I'm not sure if my Win98se real box is running at the moment, but I'll add that to the list of things to maybe try.

Have you played with a real PC emulator? That's another option, and it wouldn't have limitations like "disk IO method not supported". VirtualBox and VirtualPC are both free "full" emulators compared to DosBox's dos layer emulator, and I think there are others. But you'll probably have to mess with disk images and actually installing dos and win 3.x to try it out. It's been years since I've played with that, but was very successful.

Posted: Sat May 06, 2017 6:07 am
by Hennie
Pardon the delayed response, university's keeping me on my toes. Thank you for attempting some possible solutions, an experienced hand is always welcome. On my side, I also tried some stuff, no dice, I have limited experience, unfortunately. All this probably comes down to the simple possibility that DOSBox does not support the Runner executable.

Some simple things I tried was your recommended prompt check, there's no other shortened file names, trying to drop the .DAT file over the .EXE, swapping out files between the shareware and full version, putting the game folders in the root (C) and try running it, also tried alternating between DOSBox settings. I've also tested some games that require .DAT files, they run without hiccups, Runner really seems like the exception.

Setting up a VirtualPC emulator for Windows might be troublesome at the time, it's like I said, university studies takes up most of my time. In the future, over a holiday, I might try configuring it.

I'll be honest here, I was hoping for some easy solution (particularly getting it to run in DOSBox), but seems like it's becoming increasingly complex. The developer, SouthBay Software, doesn't exist anymore, so it's just us figuring this out. The full version I got from the WizardWorks Fun Pack 2, I hoped the error wouldn't show itself, but alas! If you want to test it out, I could share it with you (via PM), if it's allowed, it's simply contents of a compilation floppy.

I've been searching for the interesting "Windows to the World" CD, which also contains Runner in one of its packs (check the MobyGames entry), possibly the .DAT or .EXE is corrupt and somewhere a good copy might be hiding. Unfortunately this CD seems lost, there's no link or further mention anywhere.

Perhaps someone did manage to rectify this error, I don't believe it's unsolvable, I'll try asking around on some other forums, just in case. Is there anything you might recommend, some other tricks to try out and some reliable forums for information?

Again, appreciate your help! :thumbsup:

Posted: Sat May 06, 2017 3:26 pm
by Rwolf
If DOSBox is failing to run it in a Win95 emulated environment, how about Windows native compatibility mode? Or are you using a 64bit version of Windows 7, lacking native 16bit executable compatibility?

Posted: Sun May 07, 2017 5:58 am
by Hennie
It's a 64-bit version of Windows 7. If it's of any relevance or help, a more expansive list of specs are provided below:

- Model: HP Paviliion g7 Notebook PC
- Edition: Windows 7 Home Premium
- Processor: Intel Core i5-3210M CPU @ 2.50 GHz
- RAM: 4.00 GB
- System type: 64-bit
- Graphic adapters: Inter HD Graphics 4000; Radeon HD 7670M

Of course Windows 95 has its own respective settings, running with Pentium, 16 MB RAM and a S3 graphics adapter.

One thing I am curious about is how the game would run on Windows XP machines or earlier versions. That way one could possibly determine the specific settings needed to tune the game into working on DOSBox. If that makes any sense, I'm not exactly sure what will be looked at, in any case.

Posted: Sun May 07, 2017 11:30 am
by Rwolf
Got the download from [removed-incorrect-assumption] and tested on my XP32 machine, and it worked with no problems.
It does not need any installation, just unpacking of the zip.

(I set the game's .exe profile as Win95 compatible, with no DOSBox needed)

Posted: Tue May 09, 2017 10:51 am
by Hennie
Thanks for testing it in XP32. At least it's confirming that the .DAT file isn't corrupted, despite the error message. I've downloaded the selfsame file to test it in both 3.11 and 95, original problem still persists.

It comes down to the possibility that the game isn't detecting the .DAT file in a directory, even though it does exist there. Maybe it's looking somewhere else. Also, it could be that DOSBox simply doesn't like Runner and is unsupportive of the way it's opened. This is a bit hard to understand, as it's running inside Windows 95 and DOSBox is simply emulating it, other games' .DAT files are being read correctly. Emulation probably works in mysterious ways.

That being said, I'd still like to get to the bottom of this and will research a bit more, try some stuff. :cuccoan:

Posted: Tue May 09, 2017 2:20 pm
by Quadko
Cool, glad to have confirmation that the file's ok. Rock on, Rwolf!

I think it has nothing to do with .dat files (.data) themselves which isn't a standard format anyway. (Unlike, say .exe or .ini files!) Maybe lots to do with how it's trying to open files. If we magically got the dat file working, it might choke on the next file, too, whatever that might be.

I don't see a way to play it in the link. Am I missing something? I can see other games "ready to play in browser" on the site.

Posted: Tue May 09, 2017 2:27 pm
by Rwolf
Quadko wrote: -snip-
I don't see a way to play it in the link. Am I missing something? I can see other games "ready to play in browser" on the site.
No, my bad; I though it was playable, as many other games are, but now I see it's just a static screenshot. Sorry about that.

Posted: Tue May 09, 2017 2:40 pm
by Rwolf
Hmm...with later Windows, there is the issue of installation locations, and perhaps also filename upper/lower case being different to the OS.

But if I understand you correctly, you are running an actual Win95 installation from DOSBox, which is not really supported - you might possibly run out of file handles, file control blocks, buffers etc in DOSBox if Win95 itself uses up a lot of them...I suspect it would probably be issues like that in other Windows programs too.

Have you actually tried the native Win95 compatibility setting, without using DOSBox? I assume this is still available in Win7, though possibly only working with 32bit code?

Posted: Tue May 09, 2017 5:20 pm
by Quadko
Rwolf wrote:No, my bad ... Sorry about that.
No worries! Just didn't want to miss out if I was just being ig'nrant. :)

I thought they had announced something about playable Win3.x games, but wasn't sure I had seen it yet - and maybe they do but this one has same problem we're having.

Now we know the files are good, maybe it'd be worth trying it in one of the non-vanilla dosbox installs? I'll try to download and look, but happy to be preempted if anyone has that handy. IIRC, file handling was specifically on the list for at least one of them - but that might have been IDE emulation, not dos I/O.

Posted: Tue May 09, 2017 5:41 pm
by Hennie
It's a pity that there's no browser support for the game, possibly 'cause there's also errors popping up there, or no-one bothered.
Rwolf wrote:But if I understand you correctly, you are running an actual Win95 installation from DOSBox, which is not really supported - you might possibly run out of file handles, file control blocks, buffers etc in DOSBox if Win95 itself uses up a lot of them...I suspect it would probably be issues like that in other Windows programs too.
You do understand correctly. If that's the case for 95, the same might account for 3.11, as it's supposedly "easier" on DOSBox, being 16-bit and all. Then again, the differences in 3.11 regarding RAM, colors, etc. might contribute to Runner going all "screwy".

By the way, I noticed something curious in the .INI file, checking it every time after the error message popped up. The "Ypos" increases negatively from an original 0 value, only affected after the .EXE was run (or once the error is given). On YouTube, it seems the player always starts in the bottom left corner, therefore having positional values as close to (0,0), relative to the window it's running in. The .INI gives 1 for x and 0 for y, negative values would cause the player avatar appearing off-screen, which doesn't make sense. Could this possibly have a negative effect on how the game is opened in the emulator?

Another random observation, in the YouTube videos, the game is played within XP, 98 and *possibly* 2000. In each, the opening dialog box, presenting the game, there appears the @ symbol, but in XP and 98, it's not displayed correctly. Could that indicate problems running the .EXE or reading the .DAT file? Just nitpicking at anything that could give a clue.

Appreciate the help, all the way. :bday:

EDIT: Oops, overlooked your reply, Quadko, I agree about the error. I'll check if there's a downloadable one, ready-to-play, for now. Sleepy-time here :sleep:

Posted: Tue May 09, 2017 10:51 pm
by Quadko
I noticed that negative y value in the .ini file. I tried resetting it to 1, but didn't seem to make a difference.

edit: I downloaded DosBox EmuCR flavor, and no change in Win 3.11. Still the .dat file error.

Posted: Wed May 10, 2017 2:15 pm
by Hennie
If Rwolf doesn't mind, he could look for any changes made to the .INI file once the game was opened and after it was closed, it might be unrelated to the main problem we're dealing with here, but it'd be interesting to see how a working instance of the game might affect the .INI file, how XP handles it.

I've toyed with the DOSBox config again, changing memsize and some of the cpu variables, still no solution.


Posted: Wed May 10, 2017 4:53 pm
by Rwolf
I think the X/Y coordinates could be a corner of the initial window position.
If I move the window around, and then quit, the values change, and the window starts at the same location next time.

The Runner game window is 640x458 pixels - with my screen at 1600x900, placing the window roughly at center makes for Xpos=504 Ypos=251 in the file. width=(504+640+456=1600) height=(251+458+191=900).

This is probably something the game calculates at the first startup, and updates when exiting. Since the game does not launch for you, this is never calculated properly - of course you can try to manually edit the values based on your own screensize, I doubt it will help - but who knows.

Posted: Wed May 10, 2017 10:19 pm
by Quadko
A few years ago I started writing a program to crack open Win 3.x exes. I was hoping to lift dosbox or other emulation up a level, but as usual, it got back burnered. That to say, it could open lots of Win 3.x exe files with no problem, but it has a problem with Runner.

Obviously various Win OS versions manage it, and I can't see why DosBox would matter so I'm probably just missing a trick, but there's something mildly odd about it. That could also explain why it works some places and fails in others - if something's just a little off in the file...

In particular, the file format layout looks fine, but when I go to read the RELOC data - the function calls to dlls and such that need filling in during program load - the numbers come out really wrong. I'm obviously reading the wrong spot in the file, but it's usually the right spot in most Win3.x programs...

More mystery! But a fun tangent if I can figure out what I'm missing and see if that yields any answers. And maybe contributes to a hobby project.


And I downloaded and started to setup the free Microsoft Virtual PC for a Win 3.x "real VM". Now just need to setup the computer from bare virtual metal... it's been a while! Boy I love modern thumbdrive installs.

And success! Win3.1 runs in Virtual PC, Runner runs in Win 3.1. The game worked, though I noticed a few minor graphical glitches during start screens, had to hit the mouse buttons. Might be VM, might be the app...

So, free Virtual PC vm, and Win 3.1 - used a dos 6.22 disk image to boot and a windows iso image to install Win 3.1. Virtual PC doesn't appear to support vfd "virtual floppy disks", just .ima, .img and .iso files.

And other good news, Win 95 & 98 & likely XP will work great in Virtual PC, too. As I recall, faint memory, it's not the best emulated graphics card for DirectX based video games, but early stuff and desktop stuff shouldn't mind.

edit: VirtualPC accepts both img and ima floppy images, updated with correct details. Just no .vfd or .imz, as far as I know.

Posted: Fri May 12, 2017 4:59 pm
by Hennie
Quadko, thank you for your trouble with VirtualPC, glad to see there's finally an option to enjoy Runner, apart from running an ancient OS machine. Are there any tutorials you recommend for getting it up and running? Usually one setup guide isn't sufficient, as I've found with installing Win95 :shifty: .

You mentioned DirectX might have some hiccups, of course a compatible update to the API could be installed in 95 via VirtualPC, as some DOSBox tutorials respectively point out? I tend to try out a variety of games on emulators, that's why I'd like to 'prepare' it for that reason.

And lastly, will you still be experimenting with Runner in a DOSBox environment? Needless to say, it feels a bit like unfinished business still having that error pop up, a niggling in the back of the mind. While I'll attempt to get VirtualPC running, there's also some more hardware I can try add in DOSBox'd 95, see if it makes any difference, some guides provide a list of things to 'enhance' the gaming experience. :karate: cheers!