Need help with Steam and DOSBox

Post problems with getting games installed and running properly here.
Post Reply
User avatar
Grimusaur
Newbie
Newbie
Posts: 2
Joined: Wed Jun 01, 2016 8:17 pm
Location: Florida, unfortunately

Need help with Steam and DOSBox

Post by Grimusaur » Wed Jun 01, 2016 9:19 pm

So I've got a CRT pixelshader set up with DOSBox (CRT.D3D.br.fx) after having replaced the version of DOSBox in the steamapps/common/Ultimate Doom/base folder and when I launch DOSBox directly from the exe in the base folder the shader works fine, drop DOOM.exe into it and the shader works fine. However if I launch the game from the Steam window (making sure to launch it with classic controls) my shader doesn't work. Why is this happening?

User avatar
MrFlibble
Demoniac Demo maniac
Demoniac Demo maniac
Posts: 2576
Joined: Sun Dec 05, 2010 11:39 am

Re: Need help with Steam and DOSBox

Post by MrFlibble » Thu Jun 02, 2016 8:05 am

I'm not familiar with how Steam launches games through DOSBox, but from what you describe I'd assume that it forces DOSBox to use a different conf file (as the use of shaders is defined in a conf file). That, or Steam uses an entirely different version of DOSBox (? no idea if it's possible though).

Why would you want to launch a game through Steam anyway? Count the hours played? Achievements?

User avatar
Grimusaur
Newbie
Newbie
Posts: 2
Joined: Wed Jun 01, 2016 8:17 pm
Location: Florida, unfortunately

Post by Grimusaur » Thu Jun 02, 2016 12:16 pm

Steam does install an older version of DOSBox with games like DOOM that need it to launch, but I've replaced it with the latest DOSBox SVN Daum. I think it might have something to do with the Steam overlay? When I change it to windowed mode and try to manually enable the shader nothing happens, and it starts itself in fullscreen mode when I launch it through Steam even though it doesn't when I launch DOSBox from the 'base' folder in the Steam directory. I'm pretty sure the fullscreen mode has something to do with the .bat file Steam reads when it launches the game, so maybe the .bat is what's causing this.

Hours played, and that it's just easier to click "Play Game" than having to open DOSBox and load the exe each time. =P

EDIT: Not the .bat, Steam seems to do the same thing regardless of what I change to the .bat in the directory.

User avatar
Quadko
Darklander
Darklander
Posts: 2092
Joined: Fri Jun 24, 2011 10:07 am

Post by Quadko » Thu Jun 02, 2016 5:36 pm

I still suspect MrFlibble's "different conf file" is correct. If you put the usual default conf file in the dosbox exe directory, steam can override it by supplying their own and shaders, etc. won't be setup.

Here's a link that shows how to use Microsoft's Process Explorer (used to be SysInternals, MS acquired them) to show the command line.
http://superuser.com/questions/415360/h ... ng-program
If you run Doom or whatever from Steam, then find the commandline like that link says, I bet it specifies the config file you need to alter. I know Gog.com launchers do this, and their conf files sometimes have funny names you wouldn't necessarily expect.

Or possibly it's not using the copy of dosbox you think it's using... :) Process Explorer can also show the path (I think) to the dosbox.exe that Steam is using, just to double check.

I think I have some DosBox steam games. If I get a chance, I'll look to see what they are up to, but don't wait for me if you can figure it out.

User avatar
MrFlibble
Demoniac Demo maniac
Demoniac Demo maniac
Posts: 2576
Joined: Sun Dec 05, 2010 11:39 am

Post by MrFlibble » Sat Jun 04, 2016 9:39 am

Grimusaur wrote:Hours played, and that it's just easier to click "Play Game" than having to open DOSBox and load the exe each time. =P
You can create a Windows desktop shortcut that will load the game, without the need to drag'n'drop/launch the executable within DOSBox via command prompt every time. In fact, you can create a separate conf file for each game and the shortcuts that will load DOSBox with the respective conf files and get you straight into the game.

Post Reply